Tuesday, August 10, 2010

Installing ruby openssl lib

I am installing openssl lib for ruby1.9.1.
This is because I get error when I try to install ruby-debug1.9.1.
(See "Installing ruby-debug (2) post".)
The error was: no such file to load -- net/https (LoadError).
According to several blogs, it was because openssl lib is missing.

Let's install openssl lib for ruby1.9.1.

1. Open Synaptic.
2. Search for "ruby openssl"
4. Select:
libopenssl-ruby1.8 (not installed?)
libopenssl-ruby1.9.1
5. Apply.

I expected libopenssl-ruby1.8 was already installed but was not.
Though ruby-debu (1.8) was installed successfully, I decided to install it anyway.
I want my installation of ruby1.8 and 1.9.1 to be close as much as possible.

No comments:

Post a Comment