Sunday, August 29, 2010

Ruby - require 'gtk2' error, fixed

I was getting error on my laptop (not desktop pc):
Gtk-MESSAGE **:Failed to load module "pk-gtk-module": libpk-gtk-module.so
every time when I try to require 'gtk2' in ruby.

I found a workaround suggested by LeeDaugherty at
http://ubuntuforums.org/showthread.php?t=1534719

It works.
1. open gconf-editor.
2. remove check mark from /apps/gnome_settings_daemon/gtk-modules/pk-gtk-module.

No comments:

Post a Comment