Friday, January 7, 2011

Installing PS3 Media Server on Ubuntu failed

I've tried to install PS3 Media Server on my Ubuntu (10.10), but it failed.
I was reluctant to install this because it is a Java app, and it is not in Ubuntu repositories.
But I tried anyway because of good reviews.

The installer reported the following warnings and an error:
(1) It failed to install mediainfo, mplayer-mt and mencodeer-mt because I have 'maverick'.
(2) It failed to retrieve a public key.

$ sudo wget -q --no-check-certificate https://svn.paissad.net/misc/stuffs/install_PMS.sh -O /tmp/install_PMS.sh && bash /tmp/install_PMS.sh

+----------------------------------------------------------------------------+
+                     PS3MediaServer (PMS) for Linux ...                     +
+----------------------------------------------------------------------------+

Your distribution is ...: Ubuntu
Your release is ........: maverick
Your architecture is ...: i386
Your hostname is .......: ubuntu-pc


You seem to have a CPU with multithreading support.
It can be interesting to install the multithreaded versions of mlayer & mencoder.
Do you want to install mplayer-mt & mencoder-mt too ?

Enter 'yes' (y|Y) to intall or 'no' (n|N):  y
[sudo] password for socrateos: 

+----------------------------------------------------------------------------+
+ Backup /etc/apt/sources.list to /etc/apt/sources.list.2011-01-07_17:33:17  +
+----------------------------------------------------------------------------+
`/etc/apt/sources.list' -> `/etc/apt/sources.list.2011-01-07_17:33:17'

+----------------------------------------------------------------------------+
+                       Updating /etc/apt/sources.list                       +
+----------------------------------------------------------------------------+

#==================================
# Paissad Repository (pms-linux)  =
#==================================
deb http://deb.paissad.org/ unstable main contrib non-free
deb-src http://deb.paissad.org/ unstable main contrib
Warning: You have 'maverick', but the latest build of mediainfo is for 'lucid'
         We will not install mediainfo !!
         Try to build from source.
         See: http://mediainfo.sourceforge.net/ 

Warning: You have 'maverick', but the latest build for mplayer-mt,mencoder-mt is for 'karmic'
         We will not install mplayer-mt, mencoder-mt.
         Try to build from source.
         See: http://ubuntuforums.org/showthread.php?t=1049449
              http://ps3mediaserver.org/forum/viewtopic.php?f=3&t=8539 

        ANYWAY, you don't have to worrry about the warnings, PS3MediaServer
        (pms-linux) WILL RUN NORMALLY WITHOUT THOSE PACKAGES.

DONE ...

+----------------------------------------------------------------------------+
+                          Downloading public keys                           +
+----------------------------------------------------------------------------+
gpg: 有効なOpenPGPデータが見つかりません。
Error: Cannot retreive public key for http://deb.paissad.org (1) 
 

No comments:

Post a Comment